summaryrefslogtreecommitdiff
path: root/linux/runner/CMakeLists.txt
diff options
context:
space:
mode:
authorOrangerot <purple@orangerot.dev>2024-12-16 16:04:07 +0100
committerOrangerot <purple@orangerot.dev>2024-12-17 09:08:55 +0100
commit08f2adb6397557ac27cf3780aa8f8222cbc51982 (patch)
treef9ee48a8f120e9bcb93f6f172fd88a89f3d45372 /linux/runner/CMakeLists.txt
Initial Commit
Diffstat (limited to 'linux/runner/CMakeLists.txt')
-rw-r--r--linux/runner/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/linux/runner/CMakeLists.txt b/linux/runner/CMakeLists.txt
new file mode 100644
index 0000000..e97dabc
--- /dev/null
+++ b/linux/runner/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 3.13)
+project(runner LANGUAGES CXX)
+
+# Define the application target. To change its name, change BINARY_NAME in the
+# top-level CMakeLists.txt, not the value here, or `flutter run` will no longer
+# work.
+#
+# Any new source files that you add to the application should be added here.
+add_executable(${BINARY_NAME}
+ "main.cc"
+ "my_application.cc"
+ "${FLUTTER_MANAGED_DIR}/generated_plugin_registrant.cc"
+)
+
+# Apply the standard set of build settings. This can be removed for applications
+# that need different build settings.
+apply_standard_settings(${BINARY_NAME})
+
+# Add preprocessor definitions for the application ID.
+add_definitions(-DAPPLICATION_ID="${APPLICATION_ID}")
+
+# Add dependency libraries. Add any application-specific dependencies here.
+target_link_libraries(${BINARY_NAME} PRIVATE flutter)
+target_link_libraries(${BINARY_NAME} PRIVATE PkgConfig::GTK)
+
+target_include_directories(${BINARY_NAME} PRIVATE "${CMAKE_SOURCE_DIR}")